一敲OneKnock
总有你不知道的

全国计算机三级网络技术综合题总结

以下红色标注为常考点,蓝色为解释文字。

综合题1–求Ip地址

看了历年考试试卷,每年综合题第一题型都很固定。这题分必拿。

地址类别

A类首段IP是1~127,B类首段IP是128~191,C类首段IP是192~223

可以转换成二进制记,A类上限值为二进制第一个为1,100000000-1=127

B类上限值为为二进制11000000-1=191,C类同理…

有时也会告诉主机号,和子网内最后一个可用IP求其他项。子网内最后一个可用IP即广播地址减1,剩下的解题方法和上题一样,一定要找出竖线。

 

练习:

 

 

答案:

【1】111.152.13.7

【2】255.128.0.0

【3】A类

【4】111.128.0.0

【5】111.159.255.255

综合题2–配置路由

如图所示,某校园网用10Gbps 的POS技术与Internet相连,POS接口的帧格式是SDH。路由协议的选择方案是校园网内部采用OSPF协议,校园网与Internet的连接使用静态路由协议。校园网内的路由器R1设为DHCP服务器,可分配的IP地址是221.89.23.192/26,其中221.89.23.240~221.89.23.254地址除外,地址租用时间为5小时30分。

问题:
请阅读以下R3和R1的部分配置信息,并补充(1)~(5)空白处的配置命令或参数,按题目要求完成路由器的配置。
R3的POS接口、OSPF和缺省路由的配置信息
Router-R3#configure terminal
Router-R3(config)#interface pos4/0
Router-R3(config-if)#description To Internet
Router-R3(config-if)#bandwidth 10000000   //网络带宽,题目给的是10Gbps,就是10000000(10后面跟6个0)
Router-R3(config-if)#ip address 211.68.69.170.255.255.255.252
Router-R3(config-if)#crc (1) __32__    //没有特别说明是16,这里都是crc 32
Router-R3(config-if)#pos framing sdh
Router-R3(config-if)#no ip directed-broadcast
Router-R3(config-if)#pos flag s1s0 2  //帧格式是SDH填flag s1 s0 2,帧格式是sonet填flag s1 s0 0
Router-R3(config-if)#no shutdown
Router-R3(config-if)#exit
Router-R3(config)#router ospf 63
Router-R3(config-router)#network (2) __211.89.23.0 0.0.0.255__ area 0   //network  <子网地址> <wildcard-mask> area <区域号>。子网地址是下面校园网地址,wildcard-mask是ip地址子网反掩码
Router-R3(config-router)#redistribute connected metric-type 1 subnets
Router-R3(config-router)#area 0 range (3)__211.89.23.0 255.255.255.0___   //area <区域号> range <子网地址> <子网掩码>。
Router-R3(config-router)#exit
Router-R3(config)#ip route 0.0.0.0 0.0.0.0 211.68.69.169
Router-R3(config)#exit
Router-R3#
R1的DHCP的部分配置信息
Router-R1#configure terminal
Router-R1(config)#ip dhcp (4) __excluded-adress__221.89.23.240 221.89.23.254  //题目说明这里地址块除外,填excluded-adress
Router-R1(config)#ip dhcp pool bupt
Router-R1(dhcp-config)#network 221.89.23.192.255.255.255.192
Router-R1(dhcp-config)#default-router 221.89.23.1
Router-R1(dhcp-config)#domain-name bupt.edu.cn
Router-R1(dhcp-config)#dns-server address 221.89.23.27 221.89.23.26
Router-R1(dhcp-config)#lease (5) __0 50 30__  //lease是租约的意思,题目要求租用时间为5小时30分,填0 50 30
Router-R1(dhcp-config)#exit
Router-R1(config)#exit
Router-R1#

综合题3–DHCP报文分析

某客户机使用DHCP获取IP地址等信息,其获取IP地址过程中捕获的4条报文及对第2条报文分析如下图所示。请分析其中的信息,补全内容。

编号    报文摘要
1       DHCP:Request,Type:DHCP discover  //DHCP发现
2       DHCP:Reply,Type:DHCP (1) __offer__  //DHCP供给
3       DHCP:Request,Type: DHCP Request  //DHCP请求
4       DHCP:Reply,Type:DHCP ACK  //DHCP确认
DLC:—–DLC Header——-
DLC:Destination = (2) __001234567890__  //目的主机的ip地址,和下面的 Client hardware address地址一样填00123456790
DLC:Source = 001122334455
DLC:Ethertype = 0800(IP)
IP:D=(3) __192.168.0.180__ ,S=192.168.0.1  //目的地址为分配给客户端的IP地址,由下面的Client address =[192.168.0.180]知
(4) __UDP__:D=68,S=67  //DHCP服务在传输层采用UDP协议
DHCP:—-DHCP Header——-
DHCP: Boot record type   =2(Reply)

DHCP: Hardware address type =1(10M Ethernet)
DHCP: Hardware addres length =6 bytes
DHCP: Hops =0
DHCP: Transaction id =6019121F
DHCP: Elapsed boot time =0 seconds
DHCP: Flags =0000
DHCP: 0 =no broadcast
DHCP: Client self-assigned address =[0.0.0.0]
DHCP: Client address =[192.168.0.180]
DHCP: Next Server to use in bootstrap =[0.0.0.0]
DHCP: Relay Agent =[0.0.0.0]
DHCP: Client hardware address =001234567890
DHCP: Host name =“”
DHCP: Boot file name =“”
DHCP: Vendor Information tag =53825276
DHCP: Message Type =2
DHCP: Address renewel interval =345600(seconds)
DHCP: Address rebinding interval =604800(seconds)
DHCP: Request IP Address leased time =691200(seconds)
DHCP: Sever IP Address = (5) __192.168.0.1__  //DHCP服务器的IP地址,由上述IP:D=(3) __192.168.0.180__ ,S=192.168.0.1,S为source源地址意思
DHCP: Subnet mask =255.255.255.0
DHCP: Gateway address =[192.168.0.100]
DHCP: Domain Name Server address =[202.106.0.100]

图  在DHCP 客户机上捕获的报文及第2条报文的分析

综合题4–sniffer捕获数据分析

下图是校园网某台主机使用浏览器访问某个网站,在地址栏键入其URL时用sniffer捕获的数据包。请根据图中信息回答下列问题。

1)该URL的是(1) __ftp://ftp.bupt.edu.cn__。 //如果NAME=mail.**.**.***,则会问执行什么命令:tracert mail.**.**.***。如果NAME=www.***.***.***,则执行命令:ping www.***.***.***
(2)该主机的IP地址是(2) __202.113.78.113 __。
(3)图中的①②③删除了部分信息,其中①是(3) , __577568800 __②是(4)__2351764072 __ ,//对比上下SEQ ACK,SEQ+1=ACK
③是(5) __ftp.bupt.edu.cn__。//前面IP Destination address 后面格式:[服务器ip地址] 域名

Like
Like Love Haha Wow Sad Angry
2
转载请署名作者:一敲 » 全国计算机三级网络技术综合题总结
分享到: 更多 (0)

评论 1

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

一只鸽子 已经飞到了前头

Github微博