一敲OneKnock
总有你不知道的

单臂路由思科模拟器配置

环境:一台路由器,一台二层交换机,两台pc机

二层交换机的配置

一般模式:
Switch>
输入enable进入特权模式:
Switch>enable
输入configure terminal进入全局配置模式:
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
创建vlan 10 和 vlan 20:
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)# exit
进入接口配置模式:
Switch(config)#interface fastEthernet 0/1
把0/1变成trunk口(默认是access口)
Switch(config-if)#switchport mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch(config-if)#exit
进入接口配置模式分别把对应的接口,加入对应的vlan:
Switch(config)#interface fastEthernet 1/1

Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Switch(config-if)#interface fastEthernet 2/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

到此而层交换机配置完毕!

路由器的配置:

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.    ……………..进入全局配置模式
Router(config)#inter fas 0/0    …………….进入和交换机连接的那个接口

Router(config-if)#no ip address
Router(config-if)#no shutdown   …………….激活该端口

注意:单臂路由的配置父接口一定要no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int fas 0/0.10      ………..配置 子接口 这是配置单臂路由的关键,这个接口是个 逻辑接口,并不是实际存在的物理接口,但是功能却和物理接口是一样的。

%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1Q 10      …….为这个接口配置802.1Q协议,最后面的 10 是vlan 号,这也是关键部分

注意:在配置ip时一定要先封装802.1q协议
Router(config-subif)#ip address 192.168.10.1 255.255.255.0      ………为该接口划分网关地址。
Router(config-subif)#no shutdown
Router(config-subif)#int fas 0/0.20     …..同样,进入第2个子接口,进行配置

%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

Router(config-subif)#encapsulation dot1Q 20   ……..配置802.1Q协议
Router(config-subif)#ip address 192.168.20.1 255.255.255.0       ……划分网关地址和子网掩码
Router(config-subif)#no shutdown
Router(config-subif)#

查看路由表:
Router#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/0.10
C 192.168.20.0/24 is directly connected, FastEthernet0/0.20
Router#

PC0的配置:
ip 192.168.10.10
netmask 255.255.255.0
gateway 192.168.10.1

PC1的配置:
ip 192.168.20.20
netmask 255.255.255.0
gateway 192.168.20.1

两台pc,ping测试。

Like
Like Love Haha Wow Sad Angry
1
转载请署名作者:一敲 » 单臂路由思科模拟器配置
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

一只鸽子 已经飞到了前头

Github微博